Упр.76 ГДЗ Рабочая тетрадь Босова 9 класс (Информатика)

Решение #1

Изображение 76. Массив а из десяти элементов сформирован следующим образом:Алгоритмический языкнц для і от 1 до 10a[i]:=i*iкцПаскальfor i:=1 to 10 do a[i]:=i*i;ia[i]К...
Загрузка...
 

Рассмотрим вариант решения задания из учебника Босова 9 класс, Бином:
76. Массив а из десяти элементов сформирован следующим образом:
Алгоритмический язык
нц для і от 1 до 10
a[i]:=i*i
кц
Паскаль
for i:=1 to 10 do a[i]:=i*i;
i
a[i]
К данному массиву был применен следующий алгоритм:
i 1 2 3 4 5 6 7 8 9 10
a[i] 1 4 9 16 25 36 49 64 81 100

Алгоритмический язык
b:=a [10]
нц для i от 0 до 8
a [10-i]:=a[9-i]
кц
a[1]:=b
Паскаль
b:=a 10];
for i:=0 to 8 do a[10-i]:=a[9-i];
a[1]:=b;
Чему равно значение седьмого элемента обработанного массива?
Решение:
i 1 2 3 4 5 6 7 8 9 10
a[i] 100 1 4 9 16 25 36 49 64 81

a[7] = 36

Ответ: 36
*Цитирирование задания со ссылкой на учебник производится исключительно в учебных целях для лучшего понимания разбора решения задания.
*размещая тексты в комментариях ниже, вы автоматически соглашаетесь с пользовательским соглашением

Похожие решебники